summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 027007f..706a021 100644
--- a/meson.build
+++ b/meson.build
@@ -16,6 +16,8 @@ jpeg = dependency('libjpeg')
avcodec = dependency('libavcodec')
avformat = dependency('libavformat')
avutil = dependency('libavutil')
+pulse = dependency('libpulse')
+pulse_simple = dependency('libpulse-simple')
m_dep = cc.find_library('m', required: false)
if m_dep.found()
add_project_link_arguments('-lm', language: 'c')
@@ -26,5 +28,5 @@ else
debug_def = '-DDEBUG=0'
endif
executable('camlet', 'main.c', 'camera.c', 'video.c', '3rd_party/stb_image_write.c',
- dependencies: [v4l2, sdl2, sdl2_ttf, gl, udev, sodium, fontconfig, jpeg, avcodec, avformat, avutil],
+ dependencies: [v4l2, sdl2, sdl2_ttf, gl, udev, sodium, fontconfig, jpeg, avcodec, avformat, avutil, pulse, pulse_simple],
c_args: ['-Wno-unused-function', '-Wno-format-truncation', '-Wshadow', debug_def])