summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorpommicket <pommicket@gmail.com>2025-02-18 14:24:16 -0500
committerpommicket <pommicket@gmail.com>2025-02-18 14:24:16 -0500
commitabcc95a0eeffebec2924fa76f65aa758649c24e0 (patch)
treef68a08ab875d5a5b1f687147abd475710983c862 /meson.build
parentcc64f55792278bc3f336d5e000949c8e406cef67 (diff)
start menu
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index c972045..5b031a9 100644
--- a/meson.build
+++ b/meson.build
@@ -5,14 +5,16 @@ project('camlet',
]
)
-libv4l2 = dependency('libv4l2')
+v4l2 = dependency('libv4l2')
sdl2 = dependency('SDL2')
+sdl2_ttf = dependency('SDL2_ttf')
udev = dependency('libudev')
gl = dependency('GL')
sodium = dependency('libsodium')
+fontconfig = dependency('fontconfig')
if get_option('debug')
debug_def = '-DDEBUG=1'
else
debug_def = '-DDEBUG=0'
endif
-executable('camlet', 'main.c', 'lib/stb_image_write.c', dependencies: [libv4l2, sdl2, gl, udev, sodium], c_args: ['-Wno-unused-function', '-Wno-format-truncation', '-Wshadow', debug_def])
+executable('camlet', 'main.c', 'lib/stb_image_write.c', dependencies: [v4l2, sdl2, sdl2_ttf, gl, udev, sodium, fontconfig], c_args: ['-Wno-unused-function', '-Wno-format-truncation', '-Wshadow', debug_def])