summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorpommicket <pommicket@gmail.com>2025-02-23 13:52:44 -0500
committerpommicket <pommicket@gmail.com>2025-02-25 15:16:08 -0500
commit27b5aa8289330bc7b9f3499bf98a84f0127f4899 (patch)
tree7bffb0ce28a7924d425fde6fc2f7112f1b6ea7da /meson.build
parent78f28b310251cd3e35d588c9f1476e3d0ef6d983 (diff)
separate video stuff into its own file
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3c383c5..027007f 100644
--- a/meson.build
+++ b/meson.build
@@ -25,6 +25,6 @@ if get_option('debug')
else
debug_def = '-DDEBUG=0'
endif
-executable('camlet', 'main.c', 'camera.c', '3rd_party/stb_image_write.c',
+executable('camlet', 'main.c', 'camera.c', 'video.c', '3rd_party/stb_image_write.c',
dependencies: [v4l2, sdl2, sdl2_ttf, gl, udev, sodium, fontconfig, jpeg, avcodec, avformat, avutil],
c_args: ['-Wno-unused-function', '-Wno-format-truncation', '-Wshadow', debug_def])