summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorpommicket <pommicket@gmail.com>2025-02-19 18:55:55 -0500
committerpommicket <pommicket@gmail.com>2025-02-19 18:55:55 -0500
commit0ab2c540d442997360830fb1ab76284c318c28ca (patch)
tree3916d91d269192db9b4ea68a594116fd38e0bebc /meson.build
parent0b2293a1b44748e494d9db2ae72c72a16b693a9d (diff)
flash effects
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index b4acbd6..7d721bf 100644
--- a/meson.build
+++ b/meson.build
@@ -4,7 +4,7 @@ project('camlet',
'warning_level=3',
]
)
-
+cc = meson.get_compiler('c')
v4l2 = dependency('libv4l2')
sdl2 = dependency('SDL2')
sdl2_ttf = dependency('SDL2_ttf')
@@ -12,9 +12,15 @@ udev = dependency('libudev')
gl = dependency('GL')
sodium = dependency('libsodium')
fontconfig = dependency('fontconfig')
+m_dep = cc.find_library('m', required: false)
+if m_dep.found()
+ add_project_link_arguments('-lm', language: 'c')
+endif
if get_option('debug')
debug_def = '-DDEBUG=1'
else
debug_def = '-DDEBUG=0'
endif
-executable('camlet', 'main.c', 'camera.c', '3rd_party/stb_image_write.c', dependencies: [v4l2, sdl2, sdl2_ttf, gl, udev, sodium, fontconfig], c_args: ['-Wno-unused-function', '-Wno-format-truncation', '-Wshadow', debug_def])
+executable('camlet', 'main.c', 'camera.c', '3rd_party/stb_image_write.c',
+ dependencies: [v4l2, sdl2, sdl2_ttf, gl, udev, sodium, fontconfig],
+ c_args: ['-Wno-unused-function', '-Wno-format-truncation', '-Wshadow', debug_def])