summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 078ed3f..15caed1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,17 +9,10 @@ else()
set(SOURCES main.c)
endif()
-# make the file names absolute so we can go-to-error.
-set(SOURCES_ABSOLUTE )
-foreach(SOURCE ${SOURCES})
- get_filename_component(S ${CMAKE_SOURCE_DIR}/${SOURCE} ABSOLUTE)
- set(SOURCES_ABSOLUTE ${SOURCES_ABSOLUTE};${S})
-endforeach()
-
if (MSVC)
- add_executable(ted WIN32 ${SOURCES_ABSOLUTE})
+ add_executable(ted WIN32 ${SOURCES})
else()
- add_executable(ted ${SOURCES_ABSOLUTE})
+ add_executable(ted ${SOURCES})
endif()