summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpommicket <pommicket@gmail.com>2023-01-11 23:07:44 -0500
committerpommicket <pommicket@gmail.com>2023-01-11 23:07:44 -0500
commitdc1e9a3566927fe71bd254f8486be9eb99650783 (patch)
treef1ba1d9a64b392803375b1c19f7a8390e9c88188 /CMakeLists.txt
parent0c102146685ad0707ddb7e2f8ea1166782c1e76d (diff)
switch to ninja now that we strip ../ from build errors
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 078ed3f..15caed1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,17 +9,10 @@ else()
set(SOURCES main.c)
endif()
-# make the file names absolute so we can go-to-error.
-set(SOURCES_ABSOLUTE )
-foreach(SOURCE ${SOURCES})
- get_filename_component(S ${CMAKE_SOURCE_DIR}/${SOURCE} ABSOLUTE)
- set(SOURCES_ABSOLUTE ${SOURCES_ABSOLUTE};${S})
-endforeach()
-
if (MSVC)
- add_executable(ted WIN32 ${SOURCES_ABSOLUTE})
+ add_executable(ted WIN32 ${SOURCES})
else()
- add_executable(ted ${SOURCES_ABSOLUTE})
+ add_executable(ted ${SOURCES})
endif()