summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpommicket <pommicket@gmail.com>2023-10-17 13:27:30 -0400
committerpommicket <pommicket@gmail.com>2023-10-17 13:27:30 -0400
commited07fe85ec0b85d8d0ade65caac0f04b999890b4 (patch)
treee30eb2aa794e6068366086423754332f80c796f5 /CMakeLists.txt
parent7b7fb826b33773bab0cb57cc0dc234a9d7a0742e (diff)
set things up for UTF-8 PCRE2
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 238b113..74816ce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,10 +27,10 @@ if(MSVC)
set(CMAKE_C_FLAGS_DEBUG "/WX /Zi /Ob0 /Od /RTC1")
set(SDL2_LIB_DIR ${CMAKE_SOURCE_DIR}/SDL2/lib/x64)
target_link_libraries(ted ${SDL2_LIB_DIR}/SDL2.lib)
- target_link_libraries(ted ${CMAKE_SOURCE_DIR}/pcre2-32-static.lib)
+ target_link_libraries(ted ${CMAKE_SOURCE_DIR}/pcre2-32-static.lib ${CMAKE_SOURCE_DIR}/pcre2-8-static.lib)
else()
# NOTE: -gdwarf-4 is needed for valgrind to work
set(CMAKE_C_FLAGS "-Wall -Wextra -Wshadow -Wconversion -Wpedantic -pedantic -std=gnu11 -gdwarf-4 -Wno-unused-function -Wno-fixed-enum-extension -Wimplicit-fallthrough -Wno-format-truncation -Wno-unknown-warning-option")
target_link_libraries(ted m SDL2)
- target_link_libraries(ted ${CMAKE_SOURCE_DIR}/libpcre2-32.a)
+ target_link_libraries(ted ${CMAKE_SOURCE_DIR}/libpcre2-32.a ${CMAKE_SOURCE_DIR}/libpcre2-8.a)
endif()