summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d102f3d..56ea33c 100644
--- a/meson.build
+++ b/meson.build
@@ -6,4 +6,10 @@ project('camlet',
)
libv4l2 = dependency('libv4l2')
-executable('camlet', 'main.c', dependencies: [libv4l2], c_args: ['-Wno-unused-function'])
+sdl2 = dependency('SDL2')
+if get_option('debug')
+ debug_def = '-DDEBUG=1'
+else
+ debug_def = '-DDEBUG=0'
+endif
+executable('camlet', 'main.c', 'lib/stb_image_write.c', dependencies: [libv4l2, sdl2], c_args: ['-Wno-unused-function', '-Wno-format-truncation', '-Wshadow', debug_def])