summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorpommicket <pommicket@gmail.com>2025-02-15 22:31:54 -0500
committerpommicket <pommicket@gmail.com>2025-02-15 22:31:54 -0500
commit431d7a0ed866b78446bc4541b2e154c3c8272446 (patch)
tree5831605988c61f6f0b2020f541303e84696bf395 /meson.build
takin a picture
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..d102f3d
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,9 @@
+project('camlet',
+ 'c',
+ default_options: [
+ 'warning_level=4',
+ ]
+)
+
+libv4l2 = dependency('libv4l2')
+executable('camlet', 'main.c', dependencies: [libv4l2], c_args: ['-Wno-unused-function'])